金融理财

股票反转指标,wr指标高位是什么意思?

作者:caishangshibao 2021-07-14 

是“威廉”指标股票反转指标;

  威廉指标(Williams %R)或简称W%R是由拉里·威廉斯(Larry Williams)在1973年出版的《我如何赚得一百万》(How I made one million dollars last year trading commodities)一书中首先发表,这个指标是一个振荡指标,是依股价的摆动点来度量股票/指数是否处于超买或超卖的现象。它衡量多空双方创出的峰值(最高价)距每天收市价的距离与一定时间内(如7天)的股价波动范围的比例,以提供出股市趋势反转的讯号。

  指标原理

  1.威廉指标原名为“威廉氏超买超卖指标”,简称“WM%”、 “%R”、“W%R”。

  2.威廉姆斯认为:一个成功的分析系统可以把握有潜力的股票及买卖股票的最佳时机。

  3.威廉指标主要用于分析市场短期买卖走势,是测量超买超卖的简易指标。

  4.威廉指标利用摆动点来度量股市的的超买超卖现象,可以预测循环期内的高点和低点。

  应用法则

  1.当威廉指数线高于85,市场处于超卖状态,行情即将见底。

  2.当威廉指数线低于15,市场处于超买状态,行情即将见顶。

  3.与相对强弱指数配合使用,可得出对大市走向较为准确的判断。

  4.使用威廉指数作为预测市场工具,既不容易错过大的行情,也不容易在高价区套牢。

  使用方法

  当W&R高于80,即处于超卖状态,行情即将见底,应当考虑买进。

  当W&R低于20,即处于超买状态,行情即将见顶,应当考虑卖出。

  在W&R进入高位后,一般要回头,如果股价继续上升就产生了背离,是卖出信号。

  在W&R进入低位后,一般要反弹,如果股价继续下降就产生了背离。

  W&R连续几次撞顶(底),局部形成双重或多重顶(底),是卖出(买进)的信号。

  同时,使用过程中应该注意与其他技术指标相互配合。在盘整的过程中,W&R的准确性较高,而在上升或下降趋势当中,却不能只以W&R超买超卖信号作为行情判断的依据。

  背离原则

  例如

  (1)在W&R进入高位后,一般要回头,如果这时股价还继续上升,这就产生背离,是出货的信号。

  (2)在W&R进入低位后,一般要反弹,如果这时股价还继续下降,这就产生背离,是买进的信号。

  (3)W&R连续几次撞顶(底),是出货(进货)的信号。

  1.要看W&R是否也同样向 上空越50,大致上W&R5日、10 日、20日对应RSI6日、12日、24日,但是读者可能可以依照自己的测试结果,自行调整其最佳对应比例。

  2.W&R表示超买或超卖时,应立即寻求MACD讯号支援。当W&R表示超买时,应作为一种预警效果/再看MACD是否产生DIF向下交叉MACD的卖出讯号,一律以MACD的讯号为下手卖出的时机。相反的,W&R进入超卖区时,也适用同样的道理。

  3. 注意,W&R指标只适合个股,而非大盘;切适合1-3天的参考;

股票中代表资金进出的指标有哪些?

有人不肯分享,我出来分享!

股票反转指标,wr指标高位是什么意思?

MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,30);

MA4:MA(CLOSE,60);

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=-L2_AMO(0,3)/10000.0;

大S:=-L2_AMO(1,3)/10000.0;

中S:=-L2_AMO(2,3)/10000.0;

小S:=-L2_AMO(3,3)/10000.0;

净流入:(超B+大B+中B+小B)+(超S+大S+中S+小S),NODRAW;

中单:中B+中S,NODRAW;

大宗净流入:=(超B+大B)+(超S+大S);

超大单:=(超B)+(超S);

大单:=(大B)+(大S);

小单:=(小B)+(小S);

大宗进:=(超B)+(大B);

大宗出:=(超S)+(大S);

非大宗进:=(中B)+(小B);

非大宗出:=(中S)+(小S);

资金流向:=(超B+大B+中B+小B)+(超S+大S+中S+小S);

近5日流向:=SUM(资金流向,5);

近10日流向:=SUM(资金流向,10);

主力资金线:=(L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1))/100.0,LINETHICK2;

主力买力度:=LARGEINTRDVOL*100/VOL;

主力卖力度:=LARGEOUTTRDVOL*100/VOL;

AA:=CONST(MAX(ABS(净流入),MAX(ABS(大宗净流入),MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出)))))))*3,NODRAW;

DRAWRECTREL(5,CONST(830-(ABS(净流入)*500/AA)),35,945,IF(CONST(净流入)>0,RGB(250,150,10),RGB(0,100,100)));

DRAWRECTREL(40,CONST(830-(ABS(大宗净流入)*500/AA)),70,945,IF(CONST(大宗净流入)>0,RGB(250,150,10),RGB(0,100,100)));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.005,0.88,0,INTPART(净流入)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.041,0.88,0,INTPART(大宗净流入)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.008,1,0,'净大宗'),COLORWHITE;

DRAWRECTREL(80,CONST(830-(ABS(大宗进)*500/AA)),115,945,IF(CONST(大宗进)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(117,CONST(830-(ABS(大宗出)*500/AA)),152,945,IF(CONST(大宗出)<0,RGB(0,50,0),RGB(0,50,0)));

DRAWRECTREL(158,CONST(830-(ABS(非大宗进)*500/AA)),193,945,IF(CONST(非大宗进)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(195,CONST(830-(ABS(非大宗出)*500/AA)),230,945,IF(CONST(非大宗出)<0,RGB(0,50,0),RGB(0,50,0)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.09,1,0,'主进出 散进 出'),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.082,0.88,0,INTPART(大宗进)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.12,0.88,0,INTPART(大宗出)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.161,0.88,0,INTPART(非大宗进)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.196,0.88,0,INTPART(非大宗出)),COLORWHITE;

AAB:=CONST(MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单))))),NODRAW;

DRAWRECTREL(5,CONST(830-(ABS(超大单)*500/AAB))/2,35,460,IF(CONST(超大单)>0,RGB(255,0,255),RGB(0,255,255)));

DRAWRECTREL(40,CONST(830-(ABS(大单)*500/AAB))/2,70,460,IF(CONST(大单)>0,RGB(255,0,255),RGB(0,255,255)));

DRAWRECTREL(75,CONST(830-(ABS(中单)*500/AAB))/2,105,460,IF(CONST(中单)>0,RGB(255,0,255),RGB(0,255,255)));

DRAWRECTREL(110,CONST(830-(ABS(小单)*500/AAB))/2,140,460,IF(CONST(小单)>0,RGB(255,0,255),RGB(0,255,255)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.007,0.46,0,'超 大 中 散'),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.007,0.4,0,INTPART(超大单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.4,0,INTPART(大单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.076,0.4,0,INTPART(中单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.112,0.4,0,INTPART(小单)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'【资金分析¥万元】'),COLORRED;

AAC:=CONST(MAX(ABS(近5日流向),ABS(近10日流向))),NODRAW;

DRAWRECTREL(149,CONST(830-(ABS(近5日流向)*500/AAC))/2,189,460,IF(CONST(近5日流向)>0,RGB(250,150,10),RGB(0,100,100)));

DRAWRECTREL(191,CONST(830-(ABS(近10日流向)*500/AAC))/2,230,460,IF(CONST(近10日流向)>0,RGB(250,150,10),RGB(0,100,100)));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.15,0.4,0,INTPART(近5日流向)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.20,0.4,0,INTPART(近10日流向)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.13,0.47,0,'五日流 十日流'),COLORWHITE;

DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);

DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);

DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);

DRAWRECTREL(144,0,235,40,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(144,45,235,85,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(144,90,235,130,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWTEXT_FIX(1,0.15,0,0,STRCAT('DDX:',CON2STR(DDX,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0.15,0.04,0,STRCAT('DDY:',CON2STR(DDY,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0.15,0.09,0,STRCAT('DDZ:',CON2STR(DDZ,0))),COLORYELLOW;

AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

DRAWRECTREL(0,515,CONST(ABS(主力买力度)*500/AAD),568,IF(CONST(主力买力度)>0,RGB(250,150,10),RGB(0,255,255)));

DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*500/AAD),623,IF(CONST(主力卖力度)>0,RGB(23,125,255),RGB(0,255,255)));

DRAWTEXT_FIX(1,0,0.512,0,STRCAT('主力买力度:',CON2STR(主力买力度,0))),COLORRED;

DRAWTEXT_FIX(1,0,0.57,0,STRCAT('主力卖力度:',CON2STR(主力卖力度,0))),COLORRED;

本文出自: 财商时报,文章来源皆为网络整理并不代表我们的立场。